树莓派3/Raspberry pi 3 烧录刷机OpenWrt路由器

树莓派3/Raspberry pi 3 烧录刷机OpenWrt路由器

🗨

此时此刻,openwrt官方还没有支持到pi3,暂时可以使用其新团队LEDE项目应应急!

LEDE 是 OpenWrt 社区的新生,有很多目标是与 OpenWrt 相同的,但是相比于 OpenWrt 也有很大的区别。

 

注意:关于OpenWrt和树莓派3最新的安装教程,请访问 - 树莓派3/Raspberry Pi 3装Openwrt/shadowsocks/ChinaDNS

 

LEDE 当前的目标是: 

  • 构建一个巨大的嵌入式 Linux 发行版,主要关注稳定性和功能
  • 拥有规律,可预测的发行周期
  • 建立透明的决策过程,加强社区参与和公共反馈

创建 LEDE 是因为 OpenWrt 有一些长期存在的问题,一直悬而未决:

  1. 核心开发者活跃度低,也没有鼓励更多新成员加入的策略
  2. 不可靠的基础设施,因为淡点故障和内部分歧而阻碍修复
  3. 缺乏沟通,透明和协作,无论是核心团队还是核心团队与社区之间
  4. 提交 commit 的人较少,不怎么关注测试和常规构建
  5. 不关注稳定性和文档

为了解决这些问题,创建了 LEDE 项目,相比 OpenWrt 不同之处在于:

  1. 所有沟通频道都是公开的,一些对非开发成员限制只读权限
  2. 决策过程是公正公开的,大约有 50/50 的开发者和权威用户有投票权
  3. 基础设施非常简单,降低维护工作的难度
  4. 基于 OpenWrt 包在 Github 收到的反馈,合并策略更自由
  5. 强烈关注自动化测试,简历一个简单的发布流程

 LEDE下载地址:  LEDE 17.01.0 - 基于OpenWrt路由器系统支持树莓派 

1.下载镜像

         https://downloads.lede-project.org/snapshots/targets/brcm2708/bcm2710/lede-brcm2708-bcm2710-rpi-3-ext4-sdcard.img

2.刻录到tf卡,windows使用Win32DiskImager,linux使用dd命令。

3.树莓派接电,使用网线连接电脑。

4.修改/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd11:8629:b448::/48'

config interface 'lan'
         option type 'bridge'
#       option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface wan
        option proto dhcp
        option ifname eth0

5.修改/etc/wireless

config wifi-device radio0
        option type     mac80211
        option channel  11
        option hwmode   11g
        option path     'platform/soc/3f300000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option htmode   HT20
        # REMOVE THIS LINE TO ENABLE WIFI:
        option disabled 0

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     OpenWrt_RPI3
        option encryption psk2
        option key      yourwifikey

允许通过wan连接ssh

/etc/config/firewall

#open ssh on wan interface
config rule                
        option src              wan
        option dest_port        22
        option target           ACCEPT     
        option proto  


 

6.重启,网线连接路由器dhcp获取ip,电脑用wifi连接树莓派。

7.安装luci界面,可以通过浏览器访问路由

opkg install luci
/etc/init.d/uhttpd start
/etc/init.d/uhttpd enable

8.tf卡不是所有空间都用了,调整rootfs空间大小,下载Gparted系统刻录到u盘启动,启动后调整mmcblk0p2大小。

9.可以开始折腾了。


频道:硬件